DSi doesn’t like currently existing flash carts

Unfortunate news for home brewers: currently existing DS Lite flash cards don’t work with the DSi. Cards that normally boot automatically fail to do so on the new handheld, while cards that normally boot manually will show up in the DS menu, but cause an error when they attempt to load.

No news yet on whether a work around will be possible, either with existing flash carts of future models. Only time will tell.

Digg Facebook Google Buzz MySpace StumbleUpon E-mail Del.icio.us Reddit Technorati Yahoo Buzz AddThis

About the Author: Rhody Tobin